title image


Smiley Re: Probleme im Umgang mit Berichten
Hi Reinhard,es soll ein best. Datensatz abgebildet werden. Dieser DS birgt zum einen eine Menge Felder - bis dahin noch kein Problem - aber auch ein paar Gemeinheiten.1. Es gibt drei gebundene Unterformulare (die machen keine Schwierigkeiten)2. Es gibt ne Zeitangabe in Sekunden, die in Std/Min/Sek dargestellt werden soll.3. Es soll eine berechnete Anzahl von Tagen dargestellt werden (Berechnung erfolgt via VB) Aber mal von vorne man erreicht diesen Bericht über drei Stufen 1. Ein Übersichtsformular, das die wichtigsten Angaben zum betreffenden Datensatz enthält 2. Ein Formular, in dem besagter Datensatz ausführlich dargestellt wird, mit allen zu dem Datensatz vorliegenden Informationen. 3. Aufruf des Berichtes.Bis Punkt 2. gibt es keinerlei Probleme, aber dann...Die Detail-Sicht aus 2. ist wie gesagt identisch mit dem Bericht, wenn man von Kleinigkeiten wie nem aktuellen Datum, Seitenzahlen etc. absieht.In der Detailsicht rechne ich mit einer Function den o.g. Sekundenwert um in Std, Min, Sek., filtere mir die Datensätze einer andern Tabelle um besagte Anzahl von Tagen zu ermitteln füge alles via VBA in die entsprechenden Felder im Formular und ferdisch.Ich hab nun versucht den letzten Schritt in meinem Bericht genauso anzuwenden und bin kläglich gescheitert.Bei Zuweisung der Zeiten- und Tagesangabe wird die im ersten Beitrag gepostete Fehlermeldung angezeigt.Mein zweites Problem besteht darin, dass ich, um die Formatierung von best. Textfeldern zu bestimmen, ein Feldinhalt (Zelle, Wert, wie auch immer) der Datenquelle des Berichts - einer Auswahlabfrage - ermitteln möchte. Dieser Versuchwird mit der zweiten geposteten Fehlermeldung abgebrochen.Ich weis einfach nicht wo ich nen Fehler reingebaut hab.


Grüße

 

LXus

 

Win7 x64

Office 2013 x64



geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: